Strex Payment Notification - Strex Payment is partial unavailable.
Incident Report for Strex service status page
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 13:48 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 30, 2024 - 10:23 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2024 - 09:14 CEST
Investigating
ISSUE: Strex Payment is partial unavailable.
START: 05:00 30.04.2024
END: 09:00 30.04.2024
CAUSE: Unknown
Posted Apr 30, 2024 - 08:12 CEST
This incident affected: Strex Payment.