Strex Payment Notification

Incident Report for Strex

Resolved

The incident is resolved
Posted Jun 09, 2026 - 13:22 CEST

Identified

ISSUE: We are experiencing intermittent issues with charge transactions with Telia MNO. A fix is in progress.
START: Unknown

CAUSE: Error in MNO infrastructure
Posted Jun 09, 2026 - 09:24 CEST
This incident affected: Strex Payment.