Strex Payment Notification

Incident Report for Strex

Resolved

This incident has been resolved.
Posted 7 days ago. Mar 26, 2025 - 10:00 CET

Monitoring

ISSUE: High latency - timeout on payment-requests
START: 26.03.25 09:10
END: 26.03.25 09:30
CAUSE: Network error
Posted 7 days ago. Mar 26, 2025 - 09:48 CET

Investigating

ISSUE: High latency - timeout on payment-requests
START: 26.03.25 09:10
CAUSE: Unknown
Posted 7 days ago. Mar 26, 2025 - 09:21 CET
This incident affected: Strex Payment.