Strex Connect Notification, some slowness.

Incident Report for Strex

Resolved

The issues affecting our cloud provider since 19:20 have now been successfully resolved at 21:17. Normal delivery speeds for transactions and confirmations have resumed. We will maintain close monitoring moving forward.
Posted Aug 31, 2026 - 21:42 CEST

Identified

Our cloud provider has been experiencing issues since 19:20, resulting in some delays for both transactions and delivery confirmations. No messages are being stopped, but there is some slowness. We are monitoring the situation closely and are in dialogue with the cloud provider.
Posted Aug 31, 2026 - 20:25 CEST
This incident affected: Strex Connect.