Strex Payment Notification - Sell transactions for Telia failing

Incident Report for Strex

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 20:45 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2025 - 17:58 CET

Investigating

ISSUE: Sell transactions fail for some Telia subscribers
START: 04.11.2025 14:30
END: 04.11.2025 16:42
CAUSE: Error in MNO infrastructure
Posted Nov 04, 2025 - 15:59 CET
This incident affected: Strex Payment.