Strex Payment Notification
Incident Report for Strex service status page
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 13:59 CET
Monitoring
Network incident at MNO.
Traffic are coming back to normal, we will continue to monitor.
Posted Mar 06, 2024 - 10:50 CET
Investigating
ISSUE: A high count of Sell transactions are failing with "Technical Error" from MNO Telenor
START: 09:47
CAUSE: Error in MNO infrastructure
Posted Mar 06, 2024 - 10:30 CET
This incident affected: Strex Payment.