Strex Payment Notification

Incident Report for Strex

Resolved

Transactions are back to normal.
Will continue to monitor.
Posted Aug 26, 2025 - 15:40 CEST

Investigating

ISSUE: Issues with Payment API, we are investigating
START: 26.08.2025 15:05
CAUSE: Unknown
Posted Aug 26, 2025 - 15:11 CEST
This incident affected: Strex Payment.