Strex Payment notification
Incident Report for Strex service status page
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 08:05 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2024 - 09:41 CEST
Investigating
We are experiencing sporadic issues with some Telia subscribers.
We are in contact with Telia and they are investigating the issue.
Posted Apr 22, 2024 - 13:05 CEST
This incident affected: Strex Payment.